$re = '/\b(?=\w*s)(?=\w*g)(?=(\w*a){2})[sga]{4}\b/m';
$str = 'aasg assg gsaa gggh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);