re = /(view_manage_opportunities),(view_page[^,]*)/m
str = 'DCA,customer1,company1,SID1,cherie,cherie,"view_page_modulepicker,explore_more_connect with people" DCA,customer2,company2,SID2,cherie,cherie,"view_manage_opportunities,view_page_modulepicker,back_to_opp,view_page_modulepicker" DCA,customer1,company1,SID1,cherie,cherie,"view_manage_opportunities,view_page_modulepicker,explore_more_connect with people" DCA,customer1,company1,SID1,cherie,cherie,"view_page_modulepicker" DCA,customer1,company1,SID1,cherie,cherie,"view_manage_opportunities" DCA,customer4,company1,SID4,cherie,cherie,"view_manage_opportunities,view_page_actionSource" DCA,customer4,company1,SID4,cherie,cherie,"view_manage_opportunities,view_page_homePage" DCA,customer4,company1,SID4,cherie,cherie,"view_manage_opportunities,view_page_capabilities"'
subst = '$2,$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result