const regex = /^\x7f?\x7e?\x7d?\x7c?\x7b?z?y?x?w?v?u?t?s?r?q?p?o?n?m?l?k?j?i?h?g?f?e?d?c?b?a?`?\x5f?\x5e?\x5d?\x5c?\x5b?Z?Y?X?W?V?U?T?S?R?Q?P?O?N?M?L?K?J?I?H?G?F?E?D?C?B?A?@?\x3f?\x3e?\x3d?\x3c?\x3b?\x3a?9?8?7?6?5?4?3?2?1?0?\x2f?\x2e?\x2d?\x2c?\x2b?\x2a?\x29?\x28?\x27?\x26?\x25?\x24?\x23?\x22?\x21?\x20?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\x7f?\\x7e?\\x7d?\\x7c?\\x7b?z?y?x?w?v?u?t?s?r?q?p?o?n?m?l?k?j?i?h?g?f?e?d?c?b?a?`?\\x5f?\\x5e?\\x5d?\\x5c?\\x5b?Z?Y?X?W?V?U?T?S?R?Q?P?O?N?M?L?K?J?I?H?G?F?E?D?C?B?A?@?\\x3f?\\x3e?\\x3d?\\x3c?\\x3b?\\x3a?9?8?7?6?5?4?3?2?1?0?\\x2f?\\x2e?\\x2d?\\x2c?\\x2b?\\x2a?\\x29?\\x28?\\x27?\\x26?\\x25?\\x24?\\x23?\\x22?\\x21?\\x20?$', 'gm')
const str = `ae
ea
za
aA
f\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}