using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"$[1,2a,2y,5,6](\$.+){2}";
string input = @"$2y$10$8BQjxjVByHA/Ee.O1bCXtO8S7Y5WojbXWqnqYpUW.BrPx/Dlew1Va
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}