# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d-\d"
test_str = ("Hallo1-2\n"
"1. c4 e5 2. e3 c5 3. Nc3 Nc6 4. g3 f5 5. d3 Nf6 6. Bg2 d6\n"
"7. Nh3 Be6 8. Nd5 Bxd5 9. cxd5 Ne7 10. e4 h6 11. f4 Qc7\n"
"12. O-O g6 13. Bd2 Bg7 14. fxe5 dxe5 15. Rc1 Qd6 16.a3 O-O\n"
"17. Rc2 Rac8 18. b4 b6 19. Qc1 Kh7 20. bxc5 Rxc5 21. Bb4 Rxc2\n"
"22. Bxd6 Rxc1 23. Rxc1 Re8 24. Nf2 Nc8 25. Bxe5 Rxe5 26. Rxc8\n"
"Re7 27. Kf1 Ne8 28. Rc6 Rd7 29. Nh3 Nd6 30. a4 Be5 31. Nf4\n"
"fxe4 32. dxe4 Rf7 33. Ke2 Bxf4 34. gxf4 Nb7 35. e5 Nc5 36. e6\n"
"Re7 37. Bh3 Re8 38. Rc7+ Kg8 39. Rxa7 Kf8{ 40. Rf7+ Kg8 41. f5\n"
"Ne4 42. Bg2 Nd6 43. fxg6 Rc8 44. Rd7 {Rc2+ 45. Kd3 { The {Chess\n"
"Player 1851, p. 58} 1-0 F.B.I. I.R.S.} asdf CIA} 123 12345 123456 1234567 412-555-1212 a as ape d1/2-1/2 bug O-O 12345 The ape was at the apex \n\n\n\n"
"Commands:\n"
"\\{+\\w+ {+Wort ; z.B. {Chess\n"
"\\d+\\d.\n"
"\\d-\\d Zahl - Zahl; z.B. 1-1\n"
"\\d+\\. Zahl + Punkt ; z.B. 4.\n"
"(\\d\\..)\n"
"[[:digit:]]+[.]\n"
"(ape[^ ]?)\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.