#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<timestamp>[0-9]{4}-[0-9]{2}-[0-9]{2}T[0-9]{2}:[0-9]{2}:[0-9]{2}.[0-9]{6}Z) ? ? ? ? ? ?(?P<connID>[0-9]+) (?P<name>[a-zA-Z]+) (?P<sqltext>[^\n]+)"
Local $sString = "---my SQL--- " & @CRLF & _
"" & @CRLF & _
"2018-03-31T15:38:44.521650Z 2356 Query SELECT c FROM sbtest1 WHERE id=164802" & @CRLF & _
"2018-03-31T15:38:44.521790Z 2356 Query SELECT c FROM sbtest1 WHERE id BETWEEN 95241 AND 95340" & @CRLF & _
"2018-03-31T15:38:44.522168Z 2356 Query SELECT SUM(k) FROM sbtest1 WHERE id BETWEEN 1 AND 100" & @CRLF & _
"2018-03-31T15:38:44.522500Z 2356 Query SELECT c FROM sbtest1 WHERE id BETWEEN 304556 AND 304655 ORDER BY c" & @CRLF & _
"2018-03-31T15:38:44.522941Z 2356 Query SELECT DISTINCT c FROM sbtest1 WHERE id BETWEEN 924 AND 1023 ORDER BY c" & @CRLF & _
"2018-03-31T15:38:44.523525Z 2356 Query UPDATE sbtest1 SET k=k+1 WHERE id=514"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")