package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^_]+$`)
var str = `foo__bar
foo_bar
foo_bar__baz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}