$re = '/(?<!\S)[_a-z][-a-z0-9.]*/m';
$str = '-john should not be done _john 7should';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);