$re = '/^$|^(?!.*\*)\'(?! +\')[^\']+\'(,\'(?! +\')[^\']+\')*$/m';
$str = '
\'dog\',\'\'
\'cat\',\'dog\',
\' \',\'dog\'
\'cat*\',\'dog\'
\'cat\'
\'cat\',\'dog\'
\'cat\',\'dog\',\'\\car\',\'plane.gif\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);