$re = '/^(AA|BB).*(?!\1)(AA|BB)$/m';
$str = 'AA...AA
AA...BB
AA...CC
BB...AA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);