const regex = /\d(?:[ \/]+\d){0,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d(?:[ \\\/]+\\d){0,4}', 'gm')
const str = `1 2 3 4 5
123/45
1234 5
1 234 4
1/234/5
1/234 5
1 2/3 4/5
1 2345
1 ////23/////45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}