import re
regex = re.compile(r"^(?=\S)(?=(\S*\s){2,4}\S+$)[a-z\s]{8,20}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("a b\n"
" a b\n"
"a b")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")