import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<OpenTag>[\\<]+td[\\>]+)(?<Contents>[\\w\\/\\(\\)\\[\\]\\.\\&\\:\\;\\s]*?)(?<CloseTag>[\\<]+[\\/]+[td]+[\\>]+)";
final String string = "<br />\n"
+ "<span class=\"RptTitle\"><input id=\"chkPromisDataLog\" type=\"checkbox\" name=\"chkPromisDataLog\" checked=\"checked\" onclick=\"showOnOffPromisLog();\" /><label for=\"chkPromisDataLog\">Promis Processing data log [83508442.1].</label></span>\n"
+ "<div id=\"divPromisDataLog\" style=\"display: none;\">\n"
+ " <table id=\"tblPromisDataLog\" cellspacing=\"0\" cellpadding=\"0\" width=\"100%\" border=\"0\" class=\"table\">\n"
+ " <tr>\n"
+ " <td width=\"60%\"></td>\n"
+ " <td>\n"
+ " <a class=\"textnormal\" href=\"javascript:popwnd=window.open('../Tools/ExportExcel.aspx?KEY=LOT_GEN_PROMIS','popwnd','status=no,toolbar=Yes,menubar=Yes,location=no,scrollbars=yes,resizable=Yes');popwnd.focus()\">\n"
+ " Export to Excel\n"
+ " </a>\n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td colspan=\"2\">\n"
+ " <table cellspacing=\"0\" rules=\"all\" border=\"1\" id=\"dgPromisDataLog\" style=\"border-color: Black; border-collapse: collapse;\">\n"
+ " <tr class=\"rptDetailsHeaderMgt\" align=\"center\">\n"
+ " <td>LotID</td>\n"
+ " <td>Hist Stage</td>\n"
+ " <td>Datein</td>\n"
+ " <td>Dateout</td>\n"
+ " <td>Qtyin</td>\n"
+ " <td>Qtyout</td>\n"
+ " <td>M/C ID</td>\n"
+ " <td>Emp TrackOut</td>\n"
+ " <td>Hold Code</td>\n"
+ " <td>Hold Reason</td>\n"
+ " <td>Staging (Hrs)</td>\n"
+ " </tr>\n"
+ " <tr class=\"rptDetailsItemMgt\" align=\"center\" style=\"white-space: nowrap;\">\n"
+ " <td>83508442.1</td>\n"
+ " <td>\n"
+ " <a\n"
+ " href=\"javascript:popwnd=window.open('LotGen_Dtl.aspx?iDate=04/09/2021 09:07:07 PM&amp;oDate=04/10/2021 03:47:59 PM&amp;oLotid=83508442.1&amp;oStage=C-WFRPROCS&amp;oLastRow=N','popwnd','width=900,height=600,status=no,toolbar=no,menubar=no,location=no,scrollbars=yes,top=100,right=50,left=50');popwnd.focus();\"\n"
+ " >\n"
+ " C-WFRPROCS\n"
+ " </a>\n"
+ " </td>\n"
+ " <td>4/9/2021 9:07:07 PM</td>\n"
+ " <td>4/10/2021 3:47:59 PM</td>\n"
+ " <td>0</td>\n"
+ " <td>9</td>\n"
+ " <td></td>\n"
+ " <td>10911700</td>\n"
+ " <td> </td>\n"
+ " <td> </td>\n"
+ " <td>18.68</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " </td>\n"
+ " </tr>\n"
+ " </table>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}