$re = '/(^[0-9]{2})\\\\/';
$str = '28\\01\\2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);