#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\'\),')(.*)(?=\',)"
Local $sString = "DECODE(TRUE," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'410'),'Brokered'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'411'),'CDS Listing Service'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'408'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'412'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'418'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'424'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'436'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'448'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'460'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'472'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'484'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'496'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'497'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'708'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'712'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'718'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'724'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'736'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'748'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'760'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'772'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'784'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'796'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'797'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'400'),'Public Funds CD'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'700'),'Public Funds CD'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'407'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'432'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'482'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'491'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'707'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'732'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'782'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'791'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'100'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'101'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'102'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'110'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'111'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'115'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'125'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'127'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'130'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'149'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'150'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'151'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'314'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'320'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'345'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'380'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'381'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'382'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'386'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'387'),'Checking'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'330'),'HSA'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'331'),'HSA'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'161'),'Money Management'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'351'),'Money Management'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'375'),'Portfolio Investment'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'376'),'Portfolio Investment'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'377'),'Portfolio Investment'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'385'),'Portfolio Investment'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'303'),'Sweep LOC'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'841'),'Sweep LOC'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'842'),'Sweep LOC'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'843'),'Sweep LOC'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'508'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'510'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'512'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'518'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'524'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'536'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'540'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'548'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'560'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'572'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'584'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'596'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'597'),'Long Term - 1 Year or More'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'599'),'Savings'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'503'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'507'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'532'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'582'),'Short Term - Less than 1 Year'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'851'),'Holiday'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'820'),'Savings'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'825'),'Savings'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'830'),'Savings'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'845'),'Savings'," & @CRLF & _
"IN(LTRIM(RTRIM(deposit_account_type__)),'887'),'Savings'" & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")