import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(new=\\\"\\w+\\\").*(info=\\\"\\w+\\\")";
final String string = "<hello script=\"2.5\">\n"
+ "<welcome>\n"
+ " <hgsdhjaghjdghjagdjhgjdhgdajhgdajhgdhjjgfkjg\n"
+ " <number new=\"0x0000-0x3FF\" Id=\"bhi\" Range=\"4\" no_id=\"hello\" />\n"
+ " \n"
+ " < ----jsdjhsdjndkjjdhjdJHksdkjdnknnddnekfgrejgjorgj jregjgkrjglrjgojggjorjg -- >\n"
+ " < number new=\"0x02\" Id=\"bhi\" Unit=\"0\" Range=\"4\" info=\"0x00000012\" no_id=\"hi all\" />\n"
+ " < number new=\"0x04\" Id=\"bhi\" Unit=\"0\" Range=\"4\" info=\"0x0000023f\" no_id=\"dbhwd\" />\n"
+ " < ---- dfiuhdwiudi iwqdidffenfj odwqjdjqwgru jdqkkjwfkjfwn odHHOIJD JSDNKS nsk---- >\n"
+ " < number new=\"0x06\" Id=\"bhi\" Unit=\"0\" Range=\"4\" info=\"0x00000f22\" no_id=\"sjkdnkl jdsnj\" />\n"
+ " < number new=\"0x08\" Id=\"bhi\" Unit=\"0\" Range=\"4\" info=\"0x00000f1b\" no_id=\"dm o\" />\n"
+ " < -- bdheuh jwdhjwdkiwh ---- >\n"
+ " < number new=\"0x32\" Id=\"bhi\" Range=\"4\" info=\"0x000012f5\" no_id=\"he d kd\" />\n"
+ " < number new=\"0x336\" Id=\"bhi\" Range=\"4\" info=\"0x00000df2\" no_id=\"dnkwn\" />\n"
+ " < number new=\"0x428\" Id=\"bhi\" Range=\"4\" info=\"0x0001cbf2\" no_id=\"h nd\" />\n"
+ "< -- new model vdhjsb ---- >\n"
+ " < number new=\"0x06\" Id=\"bhi\" Unit=\"0\" unit_id=\"hi_all\" Range=\"2\" info=\"0x0f22\" no_id=\"sjkdnkl jdsnj' />\n"
+ " < number new=\"0x08\" Id=\"bhi\" Unit=\"0\" unit_id=\"this new\" Range=\"4\" info=\"0x00000f1b\" no_id=\"dm o\" /\n\n"
+ "< --- adhhj jdwjdkkj jsSDjkasdj jefnflefk kjsjfoekfle kajfofkp ksaokdfpef ---- >\n"
+ "< -- the end of file---- >";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}