$re = '/^(.*?[^\d])\d{2}([^\d].*?)$/m';
$str = 'skdbf12ibdfsf1265kdefj12nvds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);