import Foundation
let pattern = ##"(?:(?:https?|ftp|file):\/\/|www\.|ftp\.)(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[-A-Z0-9+&@#\/%=~_|$?!:,.])*(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[A-Z0-9+&@#\/%=~_|$])*(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[A-Z0-9+&@#\/%=~_|$;-])*"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://web.facebook.com
https://google.com
https://web.facebook.com/destiney.arkaden/posts/pfbid0jxqYa9Jkfoe9rATYUAcv9FsRnc1NGea2Kz6JxZPHKbe17xjS1akgEk5z6Z4tQTh2l?__cft__%5B0%5D=AZXy-D_E-IEYmmLc13KwLzY8E3AVjhlr1HRlJ1ejqqP1GqpRxK3ntzsoBEdpNopoBqAi_JHZJeZfYatg8ey4vsuU2vTHRjqxurMX6VYuVboZ9yAmDBWWWKdw87M6wai_ovqA-9bXektCQtxpAgNJCp0B&__tn__=%2CO%2CP-R;
<div data-slate-node="element"><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-string="true">Wondering what it takes to study in Europe?</span></span></span></span></div><div data-slate-node="element"><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-string="true">Join </span></span></span></span><a href="https://setlinn.com/profile/63cb889363b41c3cd16b37e6" target="_blank" rel="noopener noreferrer"><span data-slate-node="element" data-slate-inline="true" data-slate-void="true" contenteditable="false" data-cy="mention-Mahtabuzzaman-Rangan" class="mentionedUser" style="padding: 3px 3px 2px; margin: 0px 1px; vertical-align: baseline; display: inline-block; border-radius: 4px; font-size: 0.9em; box-shadow: none;"><span data-slate-spacer="true" style="height: 0px; color: transparent; outline: currentcolor; position: absolute;"><span data-slate-node="text"><span data-slate-leaf="true"><span data-slate-zero-width="z" data-slate-length="21"></span></span></span></span>@Mahtabuzzaman Rangan</span></a><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-string="true">as we bring him live on Facebook tomorrow to explain the step-wise processes.</span></span></span></span></div><div data-slate-node="element"><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-zero-width="z" data-slate-length="0"></span></span></span></span><a href="https://setlinn.com/profile/63a042575380303f8d583116" target="_blank" rel="noopener noreferrer"><span data-slate-node="element" data-slate-inline="true" data-slate-void="true" contenteditable="false" data-cy="mention-Michael-Onwuatuegwu" class="mentionedUser" style="padding: 3px 3px 2px; margin: 0px 1px; vertical-align: baseline; display: inline-block; border-radius: 4px; font-size: 0.9em; box-shadow: none;"><span data-slate-spacer="true" style="height: 0px; color: transparent; outline: currentcolor; position: absolute;"><span data-slate-node="text"><span data-slate-leaf="true"><span data-slate-zero-width="z" data-slate-length="20"></span></span></span></span>@Michael Onwuatuegwu</span></a><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-string="true">will be on the session too.</span></span></span></span></div><div data-slate-node="element"><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-zero-width="n" data-slate-length="0"><br></span></span></span></span></div><div data-slate-node="element"><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-string="true">Link to join ⬇️ </span></span></span></span></div><div data-slate-node="element"><span data-slate-node="text"><span data-slate-leaf="true"><span><span data-slate-string="true">https://web.facebook.com/destiney.arkaden/posts/pfbid0jxqYa9Jkfoe9rATYUAcv9FsRnc1NGea2Kz6JxZPHKbe17xjS1akgEk5z6Z4tQTh2l?__cft__%5B0%5D=AZXy-D_E-IEYmmLc13KwLzY8E3AVjhlr1HRlJ1ejqqP1GqpRxK3ntzsoBEdpNopoBqAi_JHZJeZfYatg8ey4vsuU2vTHRjqxurMX6VYuVboZ9yAmDBWWWKdw87M6wai_ovqA-9bXektCQtxpAgNJCp0B&__tn__=%2CO%2CP-R</span></span></span></span></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)