package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<meta property="og:image" content="([^"]+)">`)
var str = `<meta property="og:image" content="https://m.media-amazon.com/images/M/MV5BYWFlZGY2NDktY2ZjOS00ZWNkLTg0ZDAtZDY4MTM1ODU4ZjljXkEyXkFqcGdeQXVyMjUzOTY1NTc@._V1_UY1200_CR79,0,630,1200_AL_.jpg">"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}