re = /([^\(\)\[\]\{\}[]()〔〕〈〉【】]+)(?![^()\[\]\{\}[]()〔〕〈〉【】]*[\)\])〕〉】]])/m
str = 'hello (hi that [is] so cool) awesome {yeah}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end