re = /(?:\s+|^)(apple[!,?.'\"]*)(?=\s+|$)/m
str = 'apple apple@323 apple.. apple??...!! apple??%% Ilovesapple @apple?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end