import re
regex = re.compile(r"^5$|^5,|,5,|,5$", flags=re.MULTILINE)
test_str = ("1,6,7,3,5,15,6,25,30\n"
"5,6,7,33\n"
"1,6,29,15\n"
"4,6,7,5\n"
"4,25,5,7\n"
"5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")