$re = '/(?:^.*?)?\[@.+?\].*?(?=\[|$)/m';
$str = 'Hello [@foo] how are you [@bar] more text [@baz] again more text.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);