const regex = /\b((?:\d{1,2}(?:\.|\/|-)){2}(?:\d{4}|\d{2}))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:\\d{1,2}(?:\\.|\\\/|-)){2}(?:\\d{4}|\\d{2}))\\b', 'gm')
const str = `01.11.11 12/12/1981 1*51*12 . 22|1|13 03-02-1919 1-22-12 or 01-23-18 or 03-23-1984 01.11.18 or 2.2.17 or 02.02.18 or 12.1.16 12.23.1943 01-23-11 not 12.23.192 not 02.02.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}