#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^@([^\s]+).+global\s+([^\s]+)\s+([^,]+).+"
Local $sString = "; ModuleID = 'foo.c'" & @CRLF & _
"source_filename = "foo.c"" & @CRLF & _
"target datalayout = "e-m:e-p270:32:32-p271:32:32-p272:64:64-i64:64-f80:128-n8:16:32:64-S128"" & @CRLF & _
"target triple = "x86_64-pc-linux-gnu"" & @CRLF & _
"" & @CRLF & _
"@Test = dso_local global i32 5, align 4" & @CRLF & _
"" & @CRLF & _
"; Function Attrs: noinline nounwind optnone uwtable" & @CRLF & _
"define dso_local void @main() #0 {" & @CRLF & _
" ret void" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"attributes #0 = { noinline nounwind optnone uwtable "correctly-rounded-divide-sqrt-fp-math"="false" "disable-tail-calls"="false" "frame-pointer"="all" "less-precise-fpmad"="false" "min-legal-vector-width"="0" "no-infs-fp-math"="false" "no-jump-tables"="false" "no-nans-fp-math"="false" "no-signed-zeros-fp-math"="false" "no-trapping-math"="false" "stack-protector-buffer-size"="8" "target-cpu"="x86-64" "target-features"="+cx8,+fxsr,+mmx,+sse,+sse2,+x87" "unsafe-fp-math"="false" "use-soft-float"="false" }" & @CRLF & _
"" & @CRLF & _
"!llvm.module.flags = !{!0}" & @CRLF & _
"!llvm.ident = !{!1}" & @CRLF & _
"" & @CRLF & _
"!0 = !{i32 1, !"wchar_size", i32 4}" & @CRLF & _
"!1 = !{!"clang version 10.0.0-4ubuntu1 "}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")