import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<oxford_comma>,)(?=\\s+(and|or))";
final String string = "The canning, processing, preserving, freezing, drying, marketing, storing, packing for shipment or distribution of:\n\n"
+ "Agricultural produce;\n"
+ "Meat and fish product; and\n"
+ "Perishable foods\n\n"
+ "The canning, processing, preserving, freezing, drying, marketing, storing, packing for shipment, or distribution of:\n\n"
+ "While Sean was waiting for Kyle to pick up Chinese for dinner, he scraped the paint off the bathroom door frame, alphabetized his books by main character’s first name, and successfully startled the neighbor’s boxer twice.\n\n"
+ "The Oxford comma makes these sentences carry entirely different meanings:\n"
+ "Amanda found herself in the Winnebago with her ex-boyfriend, an herbalist and a pet detective.\n"
+ "Amanda found herself in the Winnebago with her ex-boyfriend, an herbalist, and a pet detective.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}