$re = '/\d+[w|d|m|s]/m';
$str = '4w10d50m39s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);