$re = '/.*\/(?:[^.\/]*\.){3}(?<value>[^.\/]*)[^\/]*$/m';
$str = '/apps/java/logs/abc.defgh.ijk.lm.nopqrst.uvw.xyz.log
/apps2/java/logs/abc.defgh.ijk.lm.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);