import re
regex = re.compile(r"(?i)(?<!\d)(?:1[0-2]|0?[1-9])(?::(?:[0-5][0-9]))?\s?[ap]m\s*-\s*(?:1[0-2]|0?[1-9])(?::(?:[0-5][0-9]))?\s?[ap]m\b", flags=re.MULTILINE)
test_str = ("Lorem Ipsum is dummy text of the printing and typesetting industry between 2am-8pm. : True\n"
"Contrary to popular belief, Lorem Ipsum is not simply random text. : False\n"
"Lorem has been the industry between 2:00am - 8:00pm standard dummy text since the 1500s. : True\n"
"It has survived not only five centuries, but also between 08:00am-05:00pm : True\n"
"It was popularised from 5:30am - 8:59pm with the release of Letraset sheets. : True\n"
"More recently with desktop publishing software like Aldus PageMaker 983-765-0976. : False")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")