re = /^(\d*)(?:\.)(\d*)(?:|(?:\.)(\d*))(?:|(?:\.)([a-zA-Z0-9_-]*))?$/m
str = '1.1.1.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end