package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9]+)|(ASC|DESC)`)
var str = `createdAt|ASC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}