re = /CI_ID:\K[^,]*/m
str = 'Role:Application Server, Country:Corp, CI_ID:xxx000555x76ad98325lkafd8, Application:App Name, AppEnvironment:Theta, Region:Global
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end