$re = '/\b(?!FILE)(\S+:\S+)/m';
$str = 'FILE:abc LENGTH:123 AUTHOR:Bobby
FILE:xyz LENGTH:987 AUTHOR:Sabine';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;