package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<main_title>^[A-Za-z]+)\s?\|\s?(?P<show_title>.*[^\s])\s?-\s?(?P<date>[a-zA-Z]+\s\d+)\s?-\s?(?P<show_artist>\w+\s?\W?\w+)`)
var str = `FRISKY | Sound Navigation - February 2017 - Tommi Oskari [vk.com/feelin_frisky]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}