#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(a|b)(.*)\1"
Local $sString = "accccca" & @CRLF & _
"bfffffb" & @CRLF & _
"azzzzzb" & @CRLF & _
"bttttta" & @CRLF & _
"" & @CRLF & _
"ammbmma" & @CRLF & _
"bllalla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")