$re = '/^(?!foo|bar).*\.js/m';
$str = 'test.12345.js
foo.12345.js
bar.12345.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);