package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(\\.|[^"\\])*"`)
var str = `.wa "x^2 + x + 4 = 0" "a" "b" "a"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}