package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(?:text|choice) ".*`)
var str = `text "","text1"
waitinput
text "","text2"
waitinput
text "{user}","text3"
waittext
choice "option1","option2"
text "","text4"
waitinput
text "{user}","text5"
waitinput
text "char","text6"
waitinput`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}