$re = '/(?=((?!\bword[12]\b).))/m';
$str = 'xbxbfgncmg,j6546word1^&*%*word1(hb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);