package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ca[kf]e`)
var str = `cafe
/ca[kf]e/g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}