$re = '/<LastName>(\w+)<\/LastName>(?!.*<LastName>\1<\/LastName>)/ms';
$str = ' <LastName>Adams</LastName>
<LastName>Adams</LastName>
<LastName>Yellow</LastName>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);