#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<vendor_date>\d{4}(?:\-\d\d){2} [^,]+,[^:]+):(?<vendor_level>[^:]+):(?<vendor_component>[^:]+):(?<vendor_message>[^\n\r]+)(?<vendor_details>(?(?=^\d{4}(?:\-\d\d){2})|[^\r])+)?"
Local $sString = "2019-10-14 11:07:08,727:DEBUG:certbot.cli:Var dry_run=True (set by user)." & @CRLF & _
"2019-10-14 11:07:08,727:DEBUG:certbot.cli:Var server={'dry_run', 'staging'} (set by user)." & @CRLF & _
"2019-10-14 11:07:08,727:DEBUG:certbot.cli:Var dry_run=True (set by user)." & @CRLF & _
"2019-10-14 11:07:08,728:DEBUG:certbot.cli:Var server={'dry_run', 'staging'} (set by user)." & @CRLF & _
"2019-10-14 11:07:08,728:DEBUG:certbot.cli:Var account={'server'} (set by user)." & @CRLF & _
"2019-10-14 11:07:08,757:INFO:certbot.renewal:Cert not due for renewal, but simulating renewal for dry run" & @CRLF & _
"2019-10-14 11:07:08,757:DEBUG:certbot.plugins.selection:Requested authenticator nginx and installer nginx" & @CRLF & _
"2019-10-14 11:07:10,881:DEBUG:certbot.plugins.selection:Single candidate plugin: * nginx" & @CRLF & _
"Description: Nginx Web Server plugin" & @CRLF & _
"Interfaces: IAuthenticator, IInstaller, IPlugin" & @CRLF & _
"Entry point: nginx = certbot_nginx.configurator:NginxConfigurator" & @CRLF & _
"Initialized: " & @CRLF & _
"Prep: True" & @CRLF & _
"2019-10-14 11:07:10,888:DEBUG:certbot.plugins.selection:Single candidate plugin: * nginx" & @CRLF & _
"Description: Nginx Web Server plugin" & @CRLF & _
"Interfaces: IAuthenticator, IInstaller, IPlugin" & @CRLF & _
"Entry point: nginx = certbot_nginx.configurator:NginxConfigurator" & @CRLF & _
"Initialized: " & @CRLF & _
"Prep: True" & @CRLF & _
"2019-10-14 11:07:10,889:DEBUG:certbot.plugins.selection:Selected authenticator and installer " & @CRLF & _
"2019-10-14 11:07:10,889:INFO:certbot.plugins.selection:Plugins selected: Authenticator nginx, Installer nginx" & @CRLF & _
"2019-10-14 11:07:10,902:DEBUG:certbot.main:Picked account: )>), only_return_existing=None, contact=('mailto:trol@yopmail.com',), agreement='https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf')), 019763ae9d0030f2ffa8f8cb689e7976, Meta(creation_dt=datetime.datetime(2018, 2, 27, 14, 17, 55, tzinfo=), creation_host='sd-99715.dedibox.fr'))>" & @CRLF & _
"2019-10-14 11:07:10,911:DEBUG:acme.client:Sending GET request to https://acme-staging-v02.api.letsencrypt.org/directory." & @CRLF & _
"2019-10-14 11:07:10,998:DEBUG:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): acme-staging-v02.api.letsencrypt.org" & @CRLF & _
"2019-10-14 11:07:14,617:DEBUG:requests.packages.urllib3.connectionpool:https://acme-staging-v02.api.letsencrypt.org:443 "GET /directory HTTP/1.1" 200 724" & @CRLF & _
"2019-10-14 11:07:14,619:DEBUG:acme.client:Received response:" & @CRLF & _
"HTTP 200" & @CRLF & _
"Server: nginx" & @CRLF & _
"Date: Mon, 14 Oct 2019 09:07:14 GMT" & @CRLF & _
"Content-Type: application/json" & @CRLF & _
"Content-Length: 724" & @CRLF & _
"Connection: keep-alive" & @CRLF & _
"Cache-Control: public, max-age=0, no-cache" & @CRLF & _
"X-Frame-Options: DENY" & @CRLF & _
"Strict-Transport-Security: max-age=604800" & @CRLF & _
"{" & @CRLF & _
" "kRr68eKT_x4": "https://community.letsencrypt.org/t/adding-random-entries-to-the-directory/33417"," & @CRLF & _
" "keyChange": "https://acme-staging-v02.api.letsencrypt.org/acme/key-change"," & @CRLF & _
" "meta": {" & @CRLF & _
" "caaIdentities": [" & @CRLF & _
" "letsencrypt.org"" & @CRLF & _
" ]," & @CRLF & _
" "termsOfService": "https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf"," & @CRLF & _
" "website": "https://letsencrypt.org/docs/staging-environment/"" & @CRLF & _
" }," & @CRLF & _
" "newAccount": "https://acme-staging-v02.api.letsencrypt.org/acme/new-acct"," & @CRLF & _
" "newNonce": "https://acme-staging-v02.api.letsencrypt.org/acme/new-nonce"," & @CRLF & _
" "newOrder": "https://acme-staging-v02.api.letsencrypt.org/acme/new-order"," & @CRLF & _
" "revokeCert": "https://acme-staging-v02.api.letsencrypt.org/acme/revoke-cert"" & @CRLF & _
"}" & @CRLF & _
"2019-10-14 11:07:14,620:INFO:certbot.main:Renewing an existing certificate" & @CRLF & _
"2019-10-14 11:07:14,999:DEBUG:acme.client:Requesting fresh nonce" & @CRLF & _
"2019-10-14 11:07:15,006:DEBUG:acme.client:Sending HEAD request to https://acme-staging-v02.api.letsencrypt.org/acme/new-nonce." & @CRLF & _
"2019-10-14 11:07:15,156:DEBUG:requests.packages.urllib3.connectionpool:https://acme-staging-v02.api.letsencrypt.org:443 "HEAD /acme/new-nonce HTTP/1.1" 200 0" & @CRLF & _
"2019-10-14 11:07:15,158:DEBUG:acme.client:Received response:" & @CRLF & _
"HTTP 200" & @CRLF & _
"Server: nginx" & @CRLF & _
"Date: Mon, 14 Oct 2019 09:07:15 GMT" & @CRLF & _
"Connection: keep-alive" & @CRLF & _
"Cache-Control: public, max-age=0, no-cache" & @CRLF & _
"Link: https://acme-staging-v02.api.letsencrypt.org/directory;rel="index"" & @CRLF & _
"Replay-Nonce: 0002fqXrdxZwV_xxxxx-xxxxxxxx-KdWhvOCtgFh5YNNVM" & @CRLF & _
"X-Frame-Options: DENY" & @CRLF & _
"Strict-Transport-Security: max-age=604800" & @CRLF & _
"2019-10-14 11:07:15,158:DEBUG:acme.client:Storing nonce: 0002fqXrdxZwV_xxxxx-xxxxxxxx-KdWhvOCtgFh5YNNVM " & @CRLF & _
"2019-10-14 11:07:15,160:DEBUG:acme.client:JWS payload:" & @CRLF & _
"b'{\n "identifiers": [\n {\n "type": "dns",\n "value": "site.tld"\n },\n {\n "type": "dns",\n "value": "cdn-css. site.tld "\n },\n {\n "type": "dns",\n "value": "cdn-js-body. site.tld "\n },\n {\n "type": "dns",\n "value": "cdn-js-footer. site.tld "\n },\n {\n "type": "dns",\n "value": "cdn-js-head. site.tld "\n },\n {\n "type": "dns",\n "value": "www. site.tld "\n }\n ]\n}'" & @CRLF & _
"2019-10-14 11:07:15,173:DEBUG:acme.client:Sending POST request to https://acme-staging-v02.api.letsencrypt.org/acme/new-order:" & @CRLF & _
"{" & @CRLF & _
" "protected": "SOmeBASE64Str"," & @CRLF & _
" "payload": "ANOTHERB64STR"," & @CRLF & _
" "signature": "YETANOTHERB64STR"" & @CRLF & _
"}" & @CRLF & _
"2019-10-14 11:07:15,387:DEBUG:requests.packages.urllib3.connectionpool:https://acme-staging-v02.api.letsencrypt.org:443 "POST /acme/new-order HTTP/1.1" 201 1104"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")