const regex = /^https?:\/\/([\w]{1,4}\.)?[a-z]{3,}\d{0,3}[a-z]{3,}\.li[fv]e\/(?:\d{10}|[a-z]{8})\/\?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/([\\w]{1,4}\\.)?[a-z]{3,}\\d{0,3}[a-z]{3,}\\.li[fv]e\\\/(?:\\d{10}|[a-z]{8})\\\/\\?', 'gm')
const str = `http://logar65dty.live/qxlbqlvk/?cid=^
http://logar65dty.live/kuucbxlp/?cid=^
http://logar65dty.live/volsbybp/?cid=^
http://logar65dty.live/sarcavxr/?cid=^`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}