import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<==)(?:(?!#{2}).)*";
final String string = " Identifier1 = Value1 ## Comment\n"
+ " Something = SomeData\n"
+ " Name = information\\\\t\\\\t\\\\t## More comments!\n"
+ " Nam2 = information";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}