$re = '/(?:\s|^)\(?(\d+(\.\d+)?p)\)?(\s|$)/i';
$str = '(12.2p)
12.2p
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);