package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-9]|[1-8][0-9]|9[0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-4])$`)
var str = `254`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}