$re = '/^[0-9]*\.?[0-9]{1,2}$/m';
$str = '5
5.55
0.55
.5
.55
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);