use strict;
my $str = 'M H1-1006 +Frau Mittelstädt (Herr Schröder) LF10 4 4 18.06.2019 M H1-1006 +Frau Mittelstädt (Herr Schröder) LF10 3 3 18.06.2019 Fällt
aus M H1-1107 (Frau Heinrici) LF9 2 2 18.06.2019 Fällt aus M H1-1107 (Frau Heinrici) LF9 1 1 18.06.2019 Info Art Raum Lehrer Name
Fach Pos Datum Di 18.06.2019 ALM 61 Auf 18.06. Di 3 verschoben SH J Herr Langner Sp 8 8 18.06.2019 Auf 18.06. Di 4 verschoben SH J Herr Langner Sp 7 7 18.06.2019 Fällt aus M H1-1106 (Frau Heinrici) LF7 6 6 18.06.2019 M H1-1106 +Frau Burckhardt (Frau Heinrici) LF7 5 5 18.06.2019 Von 18.06. Di 7 verschoben +SH J (M H1-2.11) +Herr Langner (Frau Mittelstädt) +Sp (SK) 4 4 18.06.2019 Von 18.06. Di 8 verschoben +SH J (M H1-2.11) +Herr Langner (Frau Mittelstädt) +Sp (SK) 3 3 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ALM 71 Fällt aus
M H1-1106 (Frau Heinrici) LF4 8 8 18.06.2019 Fällt aus M H1-1106 (Frau Heinrici) LF4 7 7 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ASH 81 Aufgaben von Frau Burchert B 129 +Aufgaben (Herr Lehmann) +LF8 (En) 4 4 18.06.2019 Aufgaben von Frau Burchert
B 129 +Aufgaben (Herr Lehmann) +LF8 (En) 3 3 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 DAD 71 Zusatzunterricht M H1-1.31 Frau Istrati DaZ 4 18.06.2019 Zusatzunterricht M H1-1.31 Frau Istrati DaZ 3 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ELB 82 M H1-2.26 +Herr Pannwitt (Herr Taubenheim) ELF 9 -1 EG 6 6 18.06.2019 M H1-2.26 +Herr Pannwitt (Herr Taubenheim) ELF 9 -1 EG 5 5 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ELE 61 ZusatzunterrichtM H1-1.31Frau IstratiDaZ318.06.2019 Raumänderung +M H1-2.26 (M H1-3.19) Herr Ehrich ELF 6 EB 2 18.06.2019 Raumänderung +M H1-2.26 (M H1-3.19) Herr Ehrich ELF 6 EB 1 18.06.2019 Info Art
Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ELE 72 Zusatzunterricht M H1-1.31 Frau Istrati DaZ 4 18.06.2019 Zusatzunterricht M H1-1.31
Frau Istrati DaZ 3 18.06.2019 Theaterworkshop B 107, B 122 Frau Völske Mitteilung 8 18.06.2019 Theaterworkshop B 107, B 122 Frau Völske Mitteilung 7 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FG 71 ET/MT/BT Fällt aus (B 112) Herr Lange Philo 10 18.06.2019 Fällt aus (B 112) Herr Lange Philo 9 18.06.2019 Raumänderung +B 111 (B 112) Frau Stöcker GpB z 4 18.06.2019 Raumänderung +B 111
(B 112) Frau Stöcker GpB z 3 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FG 73 DVT Raumänderung +B 102 (B 112) Frau
Mahncke D 7 18.06.2019 B 129 +Aufgaben (Herr Lehmann) En 6 6 18.06.2019 B 129 +Aufgaben (Herr Lehmann) En 5 5 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FG 82 BT Raumänderung +B 300 (B 102) Frau Lent En 6 6 18.06.2019 Raumänderung +B 300 (B
102) Frau Lent En 5 5 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FG 83 DVT Von 17.06. Mo 8 verschoben +SH B (B 221) +Herr Banse (Frau Thomas) +Sp (Ch) 8 8 18.06.2019 Von 17.06. Mo 7 verschoben +SH B (B 221) +Herr Banse (Frau Thomas) +Sp (Ch) 7 7 18.06.2019
Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FG 84 DVT/XTA InfoArtRaumLehrer NameFachPosDatum Zusatzunterricht M H1-1.31 Frau Istrati
DaZ 4 18.06.2019 +M H1-3.32 (M H1-2.10) +Herr Schmidt (Frau Lakner) ILF 5 3 3 18.06.2019 Zusatzunterricht M H1-1.31 Frau Istrati DaZ 3
18.06.2019 Fällt aus M H1-3.10 (Herr Patett) ILF 6 2 2 18.06.2019 Fällt aus M H1-3.10 (Herr Patett) ILF 6 1 1 18.06.2019 Info Art
Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FIN 81 +M H1-3.32 (M H1-2.10) +Herr Schmidt (Frau Lakner) ILF 5 4 4 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Raumänderung +SH B (B 122) Herr Banse D 4 18.06.2019 Raumänderung +SH B (B 122) Herr Banse D 3 18.06.2019 (B 122) Herr Banse +Sp (D) 3 3 18.06.2019 Zusatzunterricht B 109 Frau Istrati DaZ 2 18.06.2019 Fällt aus B 118c (Herr Harbrecht)
LF9 TBM 2 2 18.06.2019 Fällt aus B 301 (Herr Freiheit) LF7 FPM 2 2 18.06.2019 Zusatzunterricht B 109 Frau Istrati DaZ 1 18.06.2019 Fällt aus B 118c (Herr Harbrecht) LF9 TBM 1 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 FPM 71 TBM Raumänderung +B 101 (B 113) Frau Gottschalk BW 4 18.06.2019 Raumänderung +B 101 (B 113) Frau Gottschalk BW 3 18.06.2019 Info Art Raum Lehrer Name
Fach Pos Datum Di 18.06.2019 FS TET 81 Fällt aus M H1-2.37 (Herr Kahnke) LF13 8 8 18.06.2019 Fällt aus M H1-2.37 (Herr Kahnke) LF13 7
7 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 IME 61 Auf 18.06. Di 6 verschoben M H1-3.32 Herr Schmidt ILF 9 8 8
18.06.2019 Auf 18.06. Di 5 verschoben M H1-3.32 Herr Schmidt ILF 9 7 7 18.06.2019 Von 18.06. Di 8 verschoben +M H1-3.32 (M H1-3.10) +Herr Schmidt (Herr Patett) +ILF 9 (ILF 6) 6 6 18.06.2019 Von 18.06. Di 7 verschoben +M H1-3.32 (M H1-3.10) +Herr Schmidt (Herr Patett) +ILF 9 (ILF 6) 5 5
18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ITK 71 Zusatzunterricht M H1-1.31 Frau Istrati DaZ 4 18.06.2019 Zusatzunterricht M H1-1.31 Frau Istrati DaZ 3 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 KFM 82 Fällt ausM H1-1.17(Herr Geilus)LF88818.06.2019 Fällt aus M H1-1.17 (Herr Geilus) LF8 7 7 18.06.2019 Fällt aus M H1-1.17 (Herr Geilus) LF8 6 6 18.06.2019 M H1-1.17 +Herr Lesch (Herr Geilus) LF5 5 5 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 KOM 71 Fällt aus M H1-1.17 (Herr Geilus) LF8 8 8 18.06.2019 Fällt aus M H1-1.30 (Herr Brauckhoff) LF2 8 8 18.06.2019 Fällt aus M H1-1.30 (Herr Brauckhoff) LF2 7 7
18.06.2019 Von 19.06. Mi 7 verschoben +M H1-1.31 (M H1-1.17) +Herr Rohde (Herr Geilus) +D (LF4) 4 4 18.06.2019 Zusatzunterricht M H1-1.31 Frau
Istrati DaZ 4 18.06.2019 Von 19.06. Mi 8 verschoben +M H1-1.31 (M H1-1.17) +Herr Rohde (Herr Geilus) +D (LF4) 3 3 18.06.2019 Zusatzunterricht
M H1-1.31 Frau Istrati DaZ 3 18.06.2019 Raumänderung M H1-1.17 +Herr Dick (Herr Geilus) LF3 2 2 18.06.2019 Fällt aus M H1-1.17 (Herr Geilus) LF3 1 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 KOM 82 Zusatzunterricht B 109 Frau Istrati DaZ 2 18.06.2019 Zusatzunterricht B 109 Frau Istrati DaZ 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 MAL 71 +B 231 (B 310) +Herr Christochowitz (Frau Schulz) LF5 4 4 18.06.2019 +B 231 (B 310) +Herr Christochowitz (Frau Schulz) LF5 3 3 18.06.2019 Fällt aus
B 105 (Frau Nevermann) D 2 2 18.06.2019 Fällt aus B 105 (Frau Nevermann) D 1 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 MAL 72 Fällt aus B 129 (Herr Lehmann) En 8 8 18.06.2019 Fällt aus B 129 (Herr Lehmann) En 7 7 18.06.2019 statt 7./8.
B 118c +Herr Lehmann (Herr Harbrecht) +En (LF9) 6 6 18.06.2019 statt 7./8. B 118c +Herr Lehmann (Herr Harbrecht) +En (LF9) 5 5 18.06.2019
+B 301 (B 304) +Herr Freiheit (Herr Just) LF8 2 2 18.06.2019 +B 301 (B 304) +Herr Freiheit (Herr Just) LF8 1 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 MAU 71 MAU 71 und MAU 72 gemeinsam +B 304 (B 118c) +Herr Just (Herr Harbrecht) LF9 4 4 18.06.2019
MAU 71 und MAU 72 gemeinsam +B 304 (B 118c) +Herr Just (Herr Harbrecht) LF9 3 3 18.06.2019 Zusatzunterricht B 109 Frau Istrati DaZ 2 18.06.2019 Zusatzunterricht B 109 Frau Istrati DaZ 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 MAU 72 Fällt aus M H1-1.13 (Herr Kahnke) LF4 8 8 18.06.2019 Fällt aus M H1-1.13 (Herr Kahnke) LF4 7 7 18.06.2019 Raumänderung +M H1-1.42 (M H1-1.43, M H1-1.13) Frau Wegener D 6 18.06.2019 Raum fehlt (M H1-1.43), M H1-1.13 Herr Kahnke LF3 4 18.06.2019 Raum fehlt (M H1-1.43), M H1-1.13 Herr Kahnke LF3 3 18.06.2019 Raum fehlt (M H1-1.43), M H1-1.13 Herr Ruynat LF2 z 2 18.06.2019 Raum fehlt (M H1-1.43), M H1-1.13 Herr Ruynat LF2 z
1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 SME 83 M H1-2.28 +Herr Eisak (Herr Barz) ET 6 6 18.06.2019 M H1-2.28 +Herr Eisak (Herr Barz) ET 5 5 18.06.2019 +Herr Lübcke (Herr Barz) ET 4 4 18.06.2019 +Herr Lübcke (Herr Barz) ET 3 3 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 WER 61 +B 118c (B 310) +Herr Peters (Frau Schulz) FT 8 8 18.06.2019 +B 118c (B 310) +Herr Peters (Frau Schulz) FT 7 7 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 WER 71 2HJ Zusatzunterricht B 109 Frau Istrati DaZ 2 18.06.2019 Zusatzunterricht B 109 Frau Istrati DaZ 1 18.06.2019 Info Art Raum Lehrer Name Fach Pos Datum Di 18.06.2019 ZIM 72
';
my $regex = qr/w/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";