import re
regex = re.compile(r"^\??[a-z]+(_[a-z]+)*$|^\??(_[a-z]+){2,}(>[a-z]+)?$", flags=re.MULTILINE)
test_str = ("_cosa_cosa_cosa>cosa\n"
"cosa\n"
"?cosa\n"
"?_cosa_cosa\n"
"_cosa_cosa\n"
"cosa_cosa\n"
"cosa_\n"
"_cosa\n"
"?_cosa\n"
"?_cosa_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")