package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`linear-gradient\([^(]*(\([^)]*\)[^(]*)*[^)]*\)`)
var str = `rgba(0, 0, 0, 0) linear-gradient(45deg, rgba(126, 47, 182, 0) 0%, rgba(126, 47, 182, 0) 25%, rgba(249, 71, 157, 0) 80%, rgba(249, 71, 157, 0) 100%) repeat scroll 0% 0% / auto padding-box border-box`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}